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Chapter 5 - Inital Geometry Procedures

Geometry describes the path that the proposed roadway will follow over the existing ground. This chapter 
covers the geometry file structure for various specialty groups, geometry management concepts, and some of 
the tools to view, review, and  edit geometry.

Chapter Objectives:

 Review various geometry file structures.

 Examine the Style Manager.

 Discuss geometry file management.

 Describe how to set geometry active.

 Review the Copy, Rename, and Delete geometry commands.

 Describe how to display a variety of horizontal geometry items into the MicroStation file.

 Describe how to use Tracking.

Geometry Data Review

Section Objectives:

 Describe the types of data available from survey geometry.

 Describe the  hierarchy within a geometry project.

 Describe the layout of typical geometry project for various specialty groups.

Geometry Data from Survey

Survey data will be used as a foundation for our initial geometry work. The survey staff exports 
linear elements from the survey fieldbook as alignments and Cogo points at all survey shot 
locations. This data may be used for:

 Establishing the centerline of existing roadways

 Flow-lines of existing stream or other drainage

 Locations of existing retaining walls or bridge geometry

 Locations of existing signs or utilities

 Existing pavement limits or curb and/or gutter locations

The goal is to review some of the geometry data the survey staff produces.

The Geometry Project

The geometry project, commonly referred to as the ‘ALG’ file, is the data file that stores 
horizontal and vertical alignments, and cogo points (called the cogo buffer). An older geometry 
file may also contain superelevation data.

The hierarchical relationship between the data stored in a geometry project is illustrated below.
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Generic Geometry Project

Multiple geometry projects can be loaded into memory. However, only one geometry project 
can be active at a given time. Within the active geometry project, a single horizontal and a 
single vertical alignment can be active at any given time.

Sample Roadway Design Geometry Project

A typical design geometry project may contain horizontal alignments for the mainline, side 
roads, ditches, or alternative designs. Each horizontal alignment may have associated vertical 
alignments and superelevation solutions.
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Sample Survey Geometry Project

(Exported from a Fieldbook)

Sample Cogo Buffer Contents

A typical geometry project generated from a survey fieldbook will contain Cogo points for 
each point surveyed. These Cogo points are indexed with the shot number recorded in the field 
during collection. In addition to the Cogo points, horizontal and associated vertical alignments 
are created for each linear feature surveyed in the field such as; edge of oil, ditch or stream 
shots, or centerline shots. These alignments inherit their name from a combination of the 
survey collection code and an incremental index number.
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Sample Right of Way Geometry Project

A typical Right of Way geometry project may contain only Cogo points and horizontal 
alignments. The horizontal alignments may represent existing or proposed ROW limits, 
easement limits, section lines, and parcels. A parcel is defined as an alignment that closes on 
itself.

Section Summary:

 The Survey groups collects and stores a variety of terrain information as geometry. This 
data can be useful when developing a design project.

 The hierarchy within an alg file is, from top down: Geometry Project, Horizontal 
Alignment, Vertical Alignment

 The Cogo Buffer is on the same level as horizontal alignments in the hierarchy, but has no 
children. However, cogo points contained in th ebuffer can be used to define a horizontal 
alignment.

 The data created and stored in a geometry project may be different or have different uses 
for each specialty group, but the hierarchy  will remain the same.
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Geometry Terminology and Attributes

Section Objectives:

 Describe the various type of geometry data.

Terminology of Geometry Data Types

 Geometry Project - All geometry, whether it’s horizontal, vertical, or cogo points is stored 
in a single digital container called a Geometry Project. To put it another way, individual 
horizontal, vertical, or cogo points cannot be written to disk by themselves, only within a 
geometry project. The same is true for loading data; only geometry projects can be loaded, 
not individual alignments.

 Cogo Point - Store the x, y, and z coordinate for a specific point. The information is in the 
following format: name, x, y, and z

 Horizontal Alignment - describes a horizontal path through the project

 Vertical Alignment  - describes a vertical path through the project

 Geometry Styles - Geometry Styles are saved settings that can be assigned to a geometry 
alignment or cogo point. The Geometry Style definition stores how the alignment or cogo 
point will be displayed in the CAD file. Geometry Styles can be assigned to Points, Lines, 
Arcs, and Spirals; each style will have settings for planimetrics and annotation display. The 
Geometry Styles are defined in the Style Manager dialog box.

Style Manager – Overview

The Style Manager is used to create, edit, and delete the Geometry Styles for Points, Lines, 
Arcs, and Spirals. The symbology is edited through the Named Symbology Manager which can 
be accessed from the Style Manager. Because the styles for surface features, survey features, 
and geometry are all stored in the xin file, the Style Manager Has filters to segregate the 
different types of styles.
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 Select Tools > Style Manager

Geometry Point Symbology

Geometry Point Symbology is a saved setting for horizontal and vertical alignment keypoints 
(vertices). Each vertex will be defined in the alignment as 1of 33 possible alignment keypoints 
such as: POB, PC, PI, PT, TS, PVT, PVT, etc. Each Geometry Point can be saved as a point 
Symbol Font or Cell definition depending on the annotation settings.  geometry point 
symbology is stored in the xin file and is accessed through the Named Symbology Manager.

Section Summary:

 There are three types of geometry data in InRoads V8i: Cogo Points, Horizontal 
Alignments, and Vertical Alignments. InRoads 2004 also has Seperelevation in the 
geometry project.

 Geometry, surface feature, and survey styles are all stored in the xin file.  Filters can be 
used to isolate the geometry styles.

 Editing the xin file (through Style Manager or Named Symdology Manager) is only 
temporary. The edited attributes will be changed back the next time you log into your 
computer.

Geometry Management

Section Objectives:

 Discuss when it is appropriate to create unit specific geometry projects.

When the Survey/ROW group exports geometry from an InRoads Survey Fieldbook, the Geometry Style 
assigned to the geometry element is based on the InRoads Feature Style assigned to the surveyed element. If 
the associated Geometry Style is not found, the Style Default is used. After exporting, the user can change the 
geometry style associated with existing geometry and apply appropriate symbology. This is true if working 
with geometry generated from field survey information or from geometry created in the design process.

As standard procedure, CDOT may wish to direct each discipline to maintain independent geometry projects 
for specific projects. By doing so, the various disciplines would be responsible for maintaining their data and 
also be responsible for coordinating with other workgroups to ensure everyone is working with the correct 
foundation geometry.

Possible scenarios:

 When Survey exports the fieldbook to a geometry project it is stored in: 
Drive:\JPC#\ROW\InRoads\Geometry\ as JPC#FB2006_02_06_A.alg (FieldBook A dated 
February 06, 2006 or otherwise named)

 Design may have use for selective items such as the centerline of road, fences, utilities, etc. 
as alignments and/or Cogo points, but not need or want alignments and Cogo points for 
every single observation taken in the field. For efficiency, not to mention segregation of 
data, the roadway design discipline may wish to store the alignments they develop in: 
Drive:\JPC#\DESIGN\InRoads\ as JPC#Design.alg (or otherwise named)

 Hydraulics or Traffic may desire alignments for drainage structures, waterways, or 
pavement design or marking. There may be no need for Design or Survey to access this 
data and vice versa.
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Segregating geometry by discipline specific geometry projects lessen the possibility of loss of data through the 
regeneration of data. If the survey staff collects additional data or otherwise makes edits to the electronic 
fieldbook, they will have to re-export (regenerate) the Geometry Project to provide current information. In 
doing so, the possibility exists to over-write geometry created by other means.

Additionally, allowing individual disciplines the ability to create geometry as needed eliminates the task of 
managing who has read/write access to a single ‘master’ geometry project and when access would be available. 
However, it does raise the issue of communication. If the disciplines are dependent on geometry information 
developed by others, it is imperative that down-stream users of that information are consulted and notified of 
relevant changes.

Section Summary:

 Each specialty group should maintain there own geometry file for a specific project.  This 
reduces the possibility of data being changed or lost due to the actions of someone else.

 Maintaining seperate geometry projects requires good communication between all groups 
involved with the project so that no one is using inaccurate data.

Geometry Management Tools

Section Objectives:

 Describe how to set geometry active.

 Discuss the Copy, Delete, and Rename Geometry commands.

 Describe how to save geometry.

Setting Active Geometry

In order to use an alignment for commands like Tracking or placing MicroStation elements 
with station/offset key ins, the desired alignment must be set active. The active geometry is 
identified in the InRoads Explorer by a red box around the geometry’s icon.

A geometry project or alignment can be set active by:
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1. Select Geometry > Active Geometry from the InRoads menu bar. This displays the 
Active Geometry dialog box.

2. In the Active Geometry dialog box, set the geometry Type using drop down menu.

3. Highlight the desired geometry from the list at the bottom of the dialog box.

4. <D> Apply to make the geometry active. 

5. Reset the Type as needed to select different levels of geometry to set as active. <D> Close 
to dismiss the the Active Geometry dialog box when finished.

Geometry can also be set active by accessing the right click menu from the InRoads Explorer.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry.
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3. Select Set Active from the right click menu.

Copy Geometry

Copy Geometry can be used to copy geometry from within the same geometry project, or 
from project to project.



Page 82 Colorado Department of Transportation

Chapter 5 - Inital Geometry Procedures A Practical Guide for Using InRoads V8i SS2

Delete Geometry

Delete Geometry removes the selected geometry from the internal memory.  If the 
geometry project is then saved, the deleted data will be removed from the hard drive as well. 
The Delete Contents Only toggle deletes the data but retains the placeholder within the 
geometry project.

Rename Geometry

Rename Geometry is used to change the name of a geometry project or individual 
alignment. It is also used to add/modify a description and change the style attached to the 
selected geometry.
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Saving an Alignment

Alignments are not saved individually. Instead, they are saved when the geometry project is 
saved.  Since you are working on a copy of the geometry project that is loaded in memory, 
saving is a good idea whenever you make changes to your alignment, and mandatory before 
exiting – assuming you want to save your changes.

Geometry projects can be saved using several methods including:

Choose File > Save > Geometry Project

The active geometry project is saved.

Right-click on the Geometry Project in the Explorer menu and chose Save 

The geometry project you highlighted is saved.

If the geometry project has never been saved, either of the previous methods will bring up the 
Save > As box shown below.
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Choose File>Save As

Set the Files of Type to (*.alg)

Choose the geometry project you want to save (in the Active category)

Key in the file name (or use the default)

Choose Save and the file is saved.

Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an .alg extension. Care should be taken to make 
certain you have chosen the correct geometry project name to match the file name you specify. 
Otherwise, you could accidentally save over a file on the hard drive with the wrong geometry 
project.

The geometry project may also be saved as part of the project file or .rwk, which you will be 
using in your lab activity.

Section Summary:

 When InRoads commands, other than Roadway Designer, reference geometry, they will 
look at the active geometry only, unless the dialog box being used has an option to specify 
other geometry.

 The Copy, Delete, and Rename Geometry commands wonk on whole geometry items only 
(Geometry projects, horizontal anilgments, or vertical alignments).  The tools to edit 
alignment components are discusse din th enext chapter.

 Be careful when saving a geometry project, the name seen in InRoads does not have to be 
the same as the one on the hard drive.

Viewing Horizontal Geometry

Section Objectives:

 Describe the methods to individual view horizontal alignments.
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 Describe how to view all of the horizontal alignments in a geometry project at once.

 Describe the View Stationing command.

 Describe the Veiw Horizontal Annotation and Curve Set Annotation commands.

Horizontal geometry is used as a reference line for determining stations and offset distances in a set of design 
plans. In InRoads, viewing a horizontal alignment places graphic elements representing that alignment into the 
MicroStation dgn file. The various methods od displaying horizontal geometry information are described 
below.

Viewing the Active Horizontal Alignment

To display the active horizontal alignment into the MicroStation dgn file:

1. Select Geometry > View Geometry > Active Horizontal from the InRoads menu 
bar.

An alignment can also be viewed (displayed) from the right click menu.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry.



Page 86 Colorado Department of Transportation

Chapter 5 - Inital Geometry Procedures A Practical Guide for Using InRoads V8i SS2

3. Select View from the right click menu.

Note: Using the right click menu to view an alignment also sets that alignment active.

Viewing All Of The Alignments In A Geometry Project

All of the alignment within a single geometry project can be displayed at one time.  To view all 
of the horizontal alignments in the active geometry project:

1. Select Geometry > View Geometry > All Horizontals trom the InRoads menu bar.

All of the alignments within a geometry project can also be viewed (displayed) from the right 
click menu.

1. <D> the Geometry tab at the bottom of the InRoads Explorer.

2. <R> on the desired geometry project.
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Select View All Horizontals from the right click menu.

Note: Using the right click menu to view all horizontal alignment sets the selected 
geometry project active.

Displaying Stationing

To display the stationing of an alignment in the design file, select Geometry > View 
Geometry > Stationing.  There are several standard CDOT preferences to choose from, 
depending upon the type of alignment you’re stationing as well as the station interval. Choose 
the appropriate preference, then Apply to see the stationing. The Station lock, if on, will force 
the display to even stations.

View Horizontal Annotation

Depending on the options selected, the user can define which alignments or Cogo points are 
annotated. This dialog is accessed by selecting:

Geometry > View Geometry > Horizontal Annotation
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Main Tab

Apply Style Section Section - This section is used to determine the style used for the 
annotation.

Assigned - This option uses the geometry style assigned to the alignment or cogo point.

Active - This option uses the styles selected in the drop down menus in this section.

Override - If the Active option is selected, selecting Override will use styles selected in the 
drop down menus in this section. In addition, the style assigned to the geometry element is 
changed to the active style.

Horizontal Alignments Section - This area is used to select the alignment(s) to be annotated.

The Include field is used to specify the desired alignmnet(s). Wildcards can be used to select 

multiple alignments. An alignment can be selected graphically using the target  button.

Cogo Points Section - This area is used to select the cogo points to be annotated.

The Include field is used to specify the desired cogo points. Wildcards and point ranges can be 

used to select multiple points. A cogo point can be selected graphically using the target   

button.

Selected Section ‐ These areas show the items that will be annotated.  Alignments and cogo 

points can be annotated at the same time
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Display as Complex Linestring - When on, the alignment is displayed as a complex linestring 
(a single graphic element).  When off, each element of the alignment is a seperate graphic 
element, though they are part of the same graphic group.

Display Section - This area is used to specify the types of points  and alignment elements to be 
displayed.

 Points -  When toggled on, the points symbols for the indicated point types are displayed.

♦ On-Alignment - POB, POE, PC, and PT are examples of on-alignment points.

♦ Off-Alignment - PI, and CC are examples of off-alignment points.

♦ Event Points - These are “stations of interest”  that the user adds to the alignment.

♦ Station Equations - These alter the normal stationing of the alignment, usually to 
match that of another alignment.

 Elements - When toggled on, the indicated alignment elements are displayed.

♦ Radials - Lines from the center of curve (CC) to the PC and PT.

♦ Chords - A line from the PC to the PT.

♦ Tangents - This is the line from the PC or PT to the PI.  For a compound or spiral curve 
it is from the PC or PT on the end curve to the PI on the main curve.

♦ Subtangents - This is the line from the PC or PT to the PI.  IT is displayed for each 
curve element in a compound curve.

Annotate Section - This section is used to identify what geometry element types will be 
annotated and how it will look.

Points - Text on/off for alignment keypoints or Cogo points

Elements - Text on/off for Bearing & Distance annotation

Dual Dimension - Imperial and Metric annotation

Try Alternate Styles - On/off for using alternate geometry styles

Extend Beyond Element - The annotation is placed even if it does not fit within the 
extents of the element. This applies only to lines and circular arcs and to annotation 
placed along the element.
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Tabling Tab

The CDOT configuration is not set up to use tabling, so this tab is not described.
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Styles Tab

The Styles tab is used to specify the display properties of geometry points and elements.  The 
styles specified here are used to display all point symbols, and if specified, for element and 
annotation styles as well. 

Point Section - This area is used to specify the style used for the following geometry points:

PC - point of curvature SPI - spiral point of intersection

PI - point of intersection PCC - point of compound curvature

CC - center of curvature PRC - point of reverse curvature

PT - point of tangency SS - spiral spiral

TS - tangent to spiral POB - point of beginning

SC - spiral to curve POE - point of ending

CS - curve to spiral ST - spiral to tangent

Event Points Station Equations

Override Point Stype with Alignment Style - When selected, the annotation text of points is 
displayed using the alignments style.  The point symbol uses the style specified above.  When 
toggled off, the style specified above is used for both the point symbol and the annotation.

Display Alignment Points Similar to Cogo Points - When selected, alignment points are 
displayed using the Cogo point style.
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Element Section - This area is used to specify the style used for the following geometry 
element types:

Radials Cords

Tangents            Subtangents

Override Element Style with Alignment Style - when selected, geometry elements are 
displayed with the alignment's style. When toggled off, they are displayed with the 
style specified above.

Curve Set Annotation

Annotating horizontal alignments to the CDOT standard is a two step process covered in the 
CDOT Annotating Horizontal and Vertical Alignments workflow. The process uses the 
Horizontal Annotation command described above to annotate the linear geometry segments.  
Curve Set Annotation is used to annotate circular and spiral curves.

To annotate the curves on an alignment, select Geometry > View Geometry > Curve Set 
Annotation from the InRoads menu bar.

General Leaf

Settings on the General leaf are used to specify what part of the alignment is annotated.

 Station Limits - Determines where along the alignment that annotation will occur.  When 
toggled off, the whole alignment is annotated.  When on, only curves within the station 
extents are annotated.

 Annotate Each Element of Curve Set - When on, each part of a compound curve is 
annotated as a seperate entity.  When off a compound curve is annotated with one set of 
curve data for the whole curve set.
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 Drop Station Equation Name -  Station equations have an alph(letter) component to the 
station.   When this toggle is on, the alph component of the station is dropped from the 
annotation display.

Annotation Leaf

The Annotation leaf is used to specify what information is included in the annotation. The 
toggle headings describe what will be annotated.  The columns prrform the following 
functions:

 Column - This determines the postition of the annotation.  1 is the leftmost column moving 
to the right as the numbers increase.  These are not absolute column numbers, however.  
They indicate the order in which the data is placed when two or more items occupy the 
same row.
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 Row - With the Column entry, this determines the postition of the annotation.  1 is the 
topmost row moving to the down as the numbers increase.  These are not absolute row 
numbers, however.  They indicate the order in which the data is placed when two or more 
items occupy the same column.

 Prefix - this is text added to the front of the data.

 Suffix - this is data added to the end of the data.

 Precision - This determines the number of decimal places displayed for the data.

 Format - Specifies the style that station and slope data is doisplayed.

Note: columns are seperated by a single space.  Therefore, additional editing may be 
required to make the annotation more readable if multiple columns are used.

Section Summary:

 Annotating an alignment to the CDOT standard is a two step process.  Refer to the, “CDOT 
Annotating Horizontal and Vertical Alignments” workflow for details on this process.

 Point Symbology for horizontal annotation is taken from the Styles tab and not the 
alignment.

Reviewing Geometry

The data within a geometry project can be accessed in ways other than by displaying it to MicroStation. The 
most common is Review Geometry.

Activating the Review Geometry Command

To review a horizontal alignment select Geometry > Review Horizontal from the InRoads 
menu bar.
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The Review Horizontal Alignment dialog box can also be displayed by right clicking on the 
alignment in the InRoads explorer or information panels and selecting Review from the menu.

Once the Review Horizontal Alignment dialog box is displayed, different alignments can be 
slelcted for review. Use the Geometry Project and Horizontal Alignment drop down menus to 
select the desired alignments.

Alignments can be viewed in one of three different Modes. The most commonly used mode is 
Alignment, which displays all of the data in one window.  The other two modes  are Curve Sets 
and Element. Examples of each mode are shown below:
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Alignment Mode:

Curve Sets Mode:
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Element Mode:

Note: The Element Mode activates the navagation buttons on the right side of the dialog box. 
These are used to select different alignment elements for viewing.

Section Summary:

 Use Review Geometry to become familiar with the different alignments in the project.

 When using the Element Mode,  the alignment element represented by the data in the 
dialog box is also highlighted in the MicroStation view window.

Tracking

Tracking is used to obtain location information about MicroStation elements in relation to the active horizontal 
alignment.

Section Objectives:

 Describe general Tracking.

 Describe Horizontal Alignment Tracking.

There are two methods of tracking a horizontal alignment.
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Tools > Tracking > Tracking – Tracks both the active horizontal alignment and the active 
surface.  After applying the command, data point a location in the design file and the requested 
information is displayed graphically.  The listed elevation is read from the surface at the cursor 
location, not at the alignment.

Settings

The Settings button is used to display the Tracking Symbology dialog box.  It is used to turn on 
or off the data types displayed in the Tracking dialog box. It is also used to define the 
symbology for tracking data displayed in the MicroStation dgn file.

Displaying Tracking Data

To display the data in the Tracking dialog box to the MicroStation dgn file, <D> on the desired 
location. To select an exact point on a grapic element, <T> to the desired point then <D>.
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Tools > Tracking > Horizontal Alignment – Tracks the horizontal alignment with a 
perpendicular line to your cursor. Gives a Station, Offset, Elevation readout in the message 
field, where the elevation is read from the active vertical alignment at the given station, not 
from the DTM.

If a second horizontal alignment is selected, the offset will be between the two alignments, 
perpendicular to the first.

Section Summary:

 Both tracking options report stations relative to the active alignment.

 General Tracking gives elevation data based on the active surface, Horizontal Alignment 
Tracking gives elevation data based on the active Vertical Alignment.

 General Tracking data can be displayed into the MicroStation dgn file.

Chapter Summary:

 The Geometry Project contains Horizontal Alignments, Vertical Alignments, and Cogo 
Points.

 Multiple geometry projects can be loaded at one time, but only the active project will be 
accessed by the program when executing a command.

 Geometry Styles are stored in the CDOT_Civil.xin file along with Survey and Surface 
styles.  Changes to the styles should be requested through the CADD Manager’s office.

 The Copy, Rename, and Delete Geometry commands work on geometry projects and 
horizontal and vertical alignments as a whole.  To learn about modifying alignment 
elements, see Defining Horizontal Alignments. 

 Viewing geometry writes the data graphically into the MicroStation dgn file.

 Viewing annotation writes text data about the alignment into the MicroStation dgn file.

 The review geometry command displays alignment data in a dialog box.  The data in the 
dialog box can be written to a text file.

 Tracking is used to identify station locations of items displayed in the MicroStation dgn 
file. With general Tracking, the data can be written into the dgn file.
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